网络虚拟化

KVM:

全称是Kernel-based Virtual Machine(基于内核的虚拟机),是一种典型II型全虚拟化,它之所以叫做基于内核的虚拟机;先给主机安装常规操作系统,将KVM程序模块安装在操作系统内核中来实现虚拟化功能。

KVM程序模块只能实现CPU和内存虚拟化,IO虚拟化由kvm-qemu实现。

KVM体系架构

libvirt 主要是用于管理KVM和Hypervisor
virt-manager 是kvm图形化管理工具
virt-install 是kvm的CLI命令,主要是用于创建虚拟机
virt-viewer 显示虚拟机的图形控制台的最小工具

KVM常用命令: https://cloud.tencent.com/developer/article/1026020

FusionCompute定义
FusionCompute是一款云操作系统软件,主要实现对虚拟资源、用户资源、业务资源进行管理与调度,从而降低企业运行成本实现绿色节能。

FusionCompute架构

VRM: 虚拟资源管理,主要为管理员提供图形化管理界面,实现对资源的管理。一般通过虚拟机部署,可支持物理机部署,可实现主备部署。
CNA: 计算节点代理,指部署华为虚拟化操作系统的主机。
UVP: 统一虚拟化平台,指华为自身的虚拟化层的叫法;
VNA: 虚拟节点代理,接收VRM下发的管理控制指令,实现VRM与CNA之间的通信。

南北向流量: 指DC外部用户访问DC内部服务器的流量
东西向流量: 指DC内服务器与服务器之间交互的流量

ARP: 地址解析协议,通过目的IP地址获取目的MAC地址,从而实现报文的正常封装与转发

PXE:

  • 设置服务器为PXE启动
  • 为PC配置DHCP、TFTP等服务
  • 通过DHCP方式获取IP地址
  • 通过TFTP将镜像包上传服务器端

交换机接收数据的行为

泛洪: 一个数据帧从交换机其中一个接口进来,从其他的接口发送出去
转发: 一个数据帧从交换机其中一个接口进来,通过查找MAC地址表之后,得到相对应的接口并发送出去
丢弃: 一个数据帧从交换机其中一个接口进来,通过查找MAC地址表之后,得到对应的接口,但出接口与入接口一致,则直接丢弃该数据帧

VLAN: 虚拟局域网,将一个局域网在逻辑上划分成多个虚拟局域网

工作原理:

在交换机接收数据帧时,会打上tag,交换机发送数据帧给终端设备时会检查tag是否与终端设备所处的VLAN相同,如果相同则剥离tag并发送给终端设备;如果不同,则丢弃该数据帧

好处:

  • 隔离广播域,抑制广播报文
  • 分隔不同用户,提高网络安全性
  • 虚拟工作组,超越传统网络的工作方式

VLAN的配置

vlan x ——创建一个VLAN
vlan batch a b c ——创建多个VLAN
vlan batch 2 to 10——创建多个VLAN
interface g0/0/1——进入g0/0/1端口
port link-type access——修改端口类型为access
port default vlan x——修改端口的PVID为x

interface g0/0/2——进入g0/0/2端口
port link-type trunk——修改端口类型为trunk
port trunk allow-pass vlan x——设置允许通过列表

display port vlan
display vlan

不同VLAN之间的通信
interface Vlanif x
ip address 192.168.x.254 24

基本概念

虚拟交换机: 指通过软件实现的运行在服务器内部的交换机。
开源虚拟机交换机——OVS:
通过软件的方式形成可以实现虚拟机之间的网络通信,也能够实现虚拟机与外界网络的访问。只能实现二层功能。
华为虚拟交换机——EVS:(增强版虚拟交换机)
虚拟交换端口: 虚拟交换机的一部分,通过与虚拟网卡相连使虚拟机能够接入到网络中。
DVS: 分布式虚拟交换机,指在FusionCompute平台上创建的逻辑交换机,为了方便对服务器上的虚拟交换机和虚拟端口进行统一管理。
上行链路: DVS上虚拟端口与物理服务器上物理网口之间的逻辑链路。
端口组: 指在DVS上创建的一组虚拟端口的集合,可对多个虚拟端口进行统一管理。可配置属性:端口类型、QoS等等。

流量走向

同主机同网段: 通过虚拟交换机转发
同主机不同网段: 通过三层物理交换机实现
不同主机: 通过三层物理交换机实现